windows环境下,在itellij IDEA中执行scala程序报错

老师您好!
我的环境是windows,JDK版本为1.7,SDK版本为2.11.0
以命令行方式执行scala没有问题,但在IDEA里执行scala就会报版本不对的错误!
如下图:
[attach]5554[/attach]
 

[attach]5555[/attach]
 
已邀请:

IT_Angel

赞同来自: wangxiaolei

感谢雷雷,问题解决了,原因是IDEA的版本太高,我换了一个低版本的就没有问题啦!
[attach]5583[/attach]
具体错误信息为:Unsupported major.minor version 52.0
idea中安装的插件scala版本和环境变量中配置的scala版本是否一致?
1、软件IntelliJ IDEA 2017.1,插件scala-intellij-bin-2017.1.15.zip
2、依赖编译和运行环境:jdk1.8.0_121,scala-sdk-2.12.1
3、windows电脑上jdk环境变量配置为jdk1.8.0_121
4、在IDEA软件中,重新编译项目:
[attach]5571[/attach]
5、运行main:
[attach]5570[/attach]

 
再给你举一个报错的例子:

把1.8jdk去掉,重新配置一个1.6的jdk。
[attach]5572[/attach]
运行main,报错现象和你的一样,入下图:
[attach]5573[/attach]
你仔细看下报错那个图,idea工具会有提示,按照提示配置成1.8jdk。

 
[attach]5575[/attach]
 
[attach]5586[/attach]
 

要回复问题请先登录注册