apache版本的lzo安装

第一步查询安装包yum list |fgrep lzo
lzo.x86_64 2.03-3.1.el6_5.1 @updates
lzo.i686 2.03-3.1.el6_5.1 base
lzo-devel.i686 2.03-3.1.el6_5.1 base
lzo-devel.x86_64 2.03-3.1.el6_5.1 base
lzo-minilzo.i686 2.03-3.1.el6_5.1 base
lzo-minilzo.x86_64 2.03-3.1.el6_5.1 base
lzop.x86_64 1.02-0.9.rc1.el6 base
python-lzo.x86_64 1.08-6.el6 epel
第二步安装
[root@liujunjie ~]# yum install lzo-devel.x86_64
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package lzo-devel.x86_64 0:2.03-3.1.el6_5.1 will be installed
--> Processing Dependency: lzo-minilzo = 2.03-3.1.el6_5.1 for package: lzo-devel-2.03-3.1.el6_5.1.x86_64
--> Processing Dependency: zlib-devel for package: lzo-devel-2.03-3.1.el6_5.1.x86_64
--> Processing Dependency: libminilzo.so.0()(64bit) for package: lzo-devel-2.03-3.1.el6_5.1.x86_64
--> Running transaction check
---> Package lzo-minilzo.x86_64 0:2.03-3.1.el6_5.1 will be installed
---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be installed
 
第三步查看安装那些
[root@liujunjie lib]# cd ..
[root@liujunjie usr]# rpm -ql lzo-devel.x86_64 0:2.03-3.1.el6_5.1
/usr/include/lzo
/usr/include/lzo/lzo1.h
/usr/include/lzo/lzo1a.h
/usr/include/lzo/lzo1b.h
/usr/include/lzo/lzo1c.h
/usr/include/lzo/lzo1f.h
/usr/include/lzo/lzo1x.h
/usr/include/lzo/lzo1y.h
/usr/include/lzo/lzo1z.h
/usr/include/lzo/lzo2a.h
/usr/include/lzo/lzo_asm.h
/usr/include/lzo/lzoconf.h
/usr/include/lzo/lzodefs.h
/usr/include/lzo/lzoutil.h
/usr/include/lzo/minilzo.h
/usr/lib64/liblzo2.so
/usr/lib64/libminilzo.so
/usr/share/doc/lzo-devel-2.03
/usr/share/doc/lzo-devel-2.03/LZO.FAQ
/usr/share/doc/lzo-devel-2.03/LZO.TXT
/usr/share/doc/lzo-devel-2.03/LZOAPI.TXT
package 0:2.03-3.1.el6_5.1 is not installed
 
没看到有native的库
已邀请:

wangxiaolei

赞同来自: 唯思可达

我在你云主机上看到的是[code=Bash][root@liujunjie ~]# yum list | grep lzo
lzo.x86_64 2.03-3.1.el6_5.1 @updates
lzo-devel.x86_64 2.03-3.1.el6_5.1 @base
lzo-minilzo.x86_64 2.03-3.1.el6_5.1 @base
hadoop-lzo.x86_64 0.4.15+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6
hadoop-lzo-debuginfo.x86_64 0.4.15+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6
hadoop-lzo-mr1.x86_64 0.4.15+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6
impala-lzo.x86_64 2.2.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6
impala-lzo-debuginfo.x86_64 2.2.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6
lzo.i686 2.03-3.1.el6_5.1 base
lzo-devel.i686 2.03-3.1.el6_5.1 base
lzo-minilzo.i686 2.03-3.1.el6_5.1 base
lzop.x86_64 1.02-0.9.rc1.el6 base
python-lzo.x86_64 1.08-6.el6 epel [/code]安装lzo执行命令yum install hadoop-lzo.x86_64

唯思可达

赞同来自: wangxiaolei

apache版本正确安装步骤
 
第一步设置yum 的repo源
进入/etc/yum.repos.d/目录下面,增加一个repo源,文件名字可以设置为cludera-gplextras5-myself.repo
[cludera-gplextras5-myself]
name = Cloudera CDH, Version (Custom)
baseurl = http://DX2/software/cloudera-gplextras5
gpgcheck = 0
 
第二步执行yum list|fgrep lzo
 
第三步从查询到的包里面安装yum install hadoop-lzo.x86_64
 
第四步查看安装了那些内容
rpm -ql hadoop-lzo.x86_64 0:0.4.15+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6
/usr/lib/hadoop/lib
/usr/lib/hadoop/lib/COPYING.hadoop-lzo
/usr/lib/hadoop/lib/hadoop-lzo-0.4.15-cdh5.4.8.jar
/usr/lib/hadoop/lib/hadoop-lzo.jar
/usr/lib/hadoop/lib/native
/usr/lib/hadoop/lib/native/libgplcompression.a
/usr/lib/hadoop/lib/native/libgplcompression.la
/usr/lib/hadoop/lib/native/libgplcompression.lai
/usr/lib/hadoop/lib/native/libgplcompression.so
/usr/lib/hadoop/lib/native/libgplcompression.so.0
/usr/lib/hadoop/lib/native/libgplcompression.so.0.0.0
 
第五步把jar包hadoop-lzo.jar,和native下面的so拷贝到 hadoop的安装目录下
私信发下那台机器,密码

要回复问题请先登录注册