Sqoop安装问题

[root@zhumac1 ~]# yum install sqoop -y
Loaded plugins: refresh-packagekit, security
base | 3.7 kB 00:00
epel | 4.3 kB 00:00
extras | 3.4 kB 00:00
updates | 3.4 kB 00:00
updates/primary_db | 3.7 MB 00:03
Setting up Install Process
No package sqoop available.
Error: Nothing to do
这个什么情况?如何才能有可用的包?

wangxiaolei

赞同来自: zhudejun_1985

没有配置Cloudera CDH的yum源,这个站在国外。 就配置成小象提供的,在zhumac2机器上放了一个配置好的文件/etc/yum.repos.d/cloudera-cdh5-myself.repo

wangxiaolei

赞同来自:

先用命令yum list | grep sqoop查下,看看有没有安装包

zhudejun_1985 - 天下大事,必作于细

赞同来自:

Transaction Summary ====================================================================================================================================== Install      19 Package(s) Total download size: 508 M Installed size: 618 M Downloading Packages: (1/19): avro-libs-1.7.6+cdh5.4.8+97-1.cdh5.4.8.p0.5.el6.noarch.rpm                                             |  56 MB     00:02      (2/19): bigtop-jsvc-0.6.0+cdh5.4.8+684-1.cdh5.4.8.p0.5.el6.x86_64.rpm                                          |  27 kB     00:00      (3/19): bigtop-tomcat-0.7.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6.noarch.rpm                                          | 7.4 MB     00:00      (4/19): bigtop-utils-0.7.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6.noarch.rpm                                           |  10 kB     00:00      (5/19): hadoop-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64.rpm                                               |  44 MB     00:01      (6/19): hadoop-0.20-mapreduce-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64.rpm                                |  40 MB     00:01      (7/19): hadoop-client-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64.rpm                                        |  32 kB     00:00      (8/19): hadoop-hdfs-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64.rpm                                          |  18 MB     00:00      (9/19): hadoop-mapreduce-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64.rpm                                     |  29 MB     00:00      (10/19): hadoop-yarn-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64.rpm                                         |  15 MB     00:00      (11/19): hive-1.1.0+cdh5.4.8+275-1.cdh5.4.8.p0.5.el6.noarch.rpm                                                |  38 MB     00:01      (12/19): hive-jdbc-1.1.0+cdh5.4.8+275-1.cdh5.4.8.p0.5.el6.noarch.rpm                                           |  40 MB     00:01      (13/19): kite-1.0.0+cdh5.4.8+41-1.cdh5.4.8.p0.5.el6.noarch.rpm                                                 |  72 MB     00:02      (14/19): parquet-1.5.0+cdh5.4.8+99-1.cdh5.4.8.p0.5.el6.noarch.rpm                                              |  30 MB     00:01      (15/19): parquet-format-2.1.0+cdh5.4.8+15-1.cdh5.4.8.p0.5.el6.noarch.rpm                                       | 462 kB     00:00      (16/19): sentry-1.4.0+cdh5.4.8+183-1.cdh5.4.8.p0.5.el6.noarch.rpm                                              |  43 MB     00:01      (17/19): solr-4.10.3+cdh5.4.8+287-1.cdh5.4.8.p0.5.el6.noarch.rpm                                               |  66 MB     00:02      (18/19): sqoop-1.4.5+cdh5.4.8+118-1.cdh5.4.8.p0.5.el6.noarch.rpm                                               | 6.0 MB     00:00      (19/19): zookeeper-3.4.5+cdh5.4.8+96-1.cdh5.4.8.p0.5.el6.x86_64.rpm                                            | 3.9 MB     00:00      -------------------------------------------------------------------------------------------------------------------------------------- Total                                                                                                  26 MB/s | 508 MB     00:19      Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction   Installing : avro-libs-1.7.6+cdh5.4.8+97-1.cdh5.4.8.p0.5.el6.noarch                                                            1/19    Installing : bigtop-utils-0.7.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6.noarch                                                          2/19    Installing : zookeeper-3.4.5+cdh5.4.8+96-1.cdh5.4.8.p0.5.el6.x86_64                                                            3/19    Installing : bigtop-tomcat-0.7.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6.noarch                                                         4/19    Installing : bigtop-jsvc-0.6.0+cdh5.4.8+684-1.cdh5.4.8.p0.5.el6.x86_64                                                         5/19    Installing : parquet-format-2.1.0+cdh5.4.8+15-1.cdh5.4.8.p0.5.el6.noarch                                                       6/19    Installing : parquet-1.5.0+cdh5.4.8+99-1.cdh5.4.8.p0.5.el6.noarch                                                              7/19    Installing : hadoop-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                              8/19    Installing : hadoop-hdfs-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                         9/19    Installing : hadoop-yarn-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                        10/19    Installing : hadoop-mapreduce-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                   11/19    Installing : hadoop-0.20-mapreduce-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                              12/19    Installing : hadoop-client-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                      13/19    Installing : hive-jdbc-1.1.0+cdh5.4.8+275-1.cdh5.4.8.p0.5.el6.noarch                                                          14/19    Installing : sentry-1.4.0+cdh5.4.8+183-1.cdh5.4.8.p0.5.el6.noarch                                                             15/19    Installing : hive-1.1.0+cdh5.4.8+275-1.cdh5.4.8.p0.5.el6.noarch                                                               16/19    Installing : solr-4.10.3+cdh5.4.8+287-1.cdh5.4.8.p0.5.el6.noarch                                                              17/19  The following warning applies to any collections configured to use Non-SolrCloud mode. Any such collection configuration will need to be upgraded, see Upgrading Cloudera Search for details.   Installing : kite-1.0.0+cdh5.4.8+41-1.cdh5.4.8.p0.5.el6.noarch                                                                18/19    Installing : sqoop-1.4.5+cdh5.4.8+118-1.cdh5.4.8.p0.5.el6.noarch                                                              19/19  Unable to connect to dbus   Verifying  : hadoop-mapreduce-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                    1/19    Verifying  : bigtop-tomcat-0.7.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6.noarch                                                         2/19    Verifying  : zookeeper-3.4.5+cdh5.4.8+96-1.cdh5.4.8.p0.5.el6.x86_64                                                            3/19    Verifying  : hadoop-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                              4/19    Verifying  : hadoop-0.20-mapreduce-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                               5/19    Verifying  : hive-jdbc-1.1.0+cdh5.4.8+275-1.cdh5.4.8.p0.5.el6.noarch                                                           6/19    Verifying  : solr-4.10.3+cdh5.4.8+287-1.cdh5.4.8.p0.5.el6.noarch                                                               7/19    Verifying  : hadoop-yarn-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                         8/19    Verifying  : bigtop-jsvc-0.6.0+cdh5.4.8+684-1.cdh5.4.8.p0.5.el6.x86_64                                                         9/19    Verifying  : avro-libs-1.7.6+cdh5.4.8+97-1.cdh5.4.8.p0.5.el6.noarch                                                           10/19    Verifying  : sentry-1.4.0+cdh5.4.8+183-1.cdh5.4.8.p0.5.el6.noarch                                                             11/19    Verifying  : sqoop-1.4.5+cdh5.4.8+118-1.cdh5.4.8.p0.5.el6.noarch                                                              12/19    Verifying  : bigtop-utils-0.7.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6.noarch                                                         13/19    Verifying  : hadoop-hdfs-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                        14/19    Verifying  : kite-1.0.0+cdh5.4.8+41-1.cdh5.4.8.p0.5.el6.noarch                                                                15/19    Verifying  : parquet-1.5.0+cdh5.4.8+99-1.cdh5.4.8.p0.5.el6.noarch                                                             16/19    Verifying  : hive-1.1.0+cdh5.4.8+275-1.cdh5.4.8.p0.5.el6.noarch                                                               17/19    Verifying  : hadoop-client-2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6.x86_64                                                      18/19    Verifying  : parquet-format-2.1.0+cdh5.4.8+15-1.cdh5.4.8.p0.5.el6.noarch                                                      19/19  Installed:   sqoop.noarch 0:1.4.5+cdh5.4.8+118-1.cdh5.4.8.p0.5.el6                                                                                Dependency Installed:   avro-libs.noarch 0:1.7.6+cdh5.4.8+97-1.cdh5.4.8.p0.5.el6                                                                               bigtop-jsvc.x86_64 0:0.6.0+cdh5.4.8+684-1.cdh5.4.8.p0.5.el6                                                                            bigtop-tomcat.noarch 0:0.7.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6                                                                            bigtop-utils.noarch 0:0.7.0+cdh5.4.8+0-1.cdh5.4.8.p0.5.el6                                                                             hadoop.x86_64 0:2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6                                                                                 hadoop-0.20-mapreduce.x86_64 0:2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6                                                                  hadoop-client.x86_64 0:2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6                                                                          hadoop-hdfs.x86_64 0:2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6                                                                            hadoop-mapreduce.x86_64 0:2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6                                                                       hadoop-yarn.x86_64 0:2.6.0+cdh5.4.8+669-1.cdh5.4.8.p0.5.el6                                                                            hive.noarch 0:1.1.0+cdh5.4.8+275-1.cdh5.4.8.p0.5.el6                                                                                   hive-jdbc.noarch 0:1.1.0+cdh5.4.8+275-1.cdh5.4.8.p0.5.el6                                                                              kite.noarch 0:1.0.0+cdh5.4.8+41-1.cdh5.4.8.p0.5.el6                                                                                    parquet.noarch 0:1.5.0+cdh5.4.8+99-1.cdh5.4.8.p0.5.el6                                                                                 parquet-format.noarch 0:2.1.0+cdh5.4.8+15-1.cdh5.4.8.p0.5.el6                                                                          sentry.noarch 0:1.4.0+cdh5.4.8+183-1.cdh5.4.8.p0.5.el6                                                                                 solr.noarch 0:4.10.3+cdh5.4.8+287-1.cdh5.4.8.p0.5.el6                                                                                  zookeeper.x86_64 0:3.4.5+cdh5.4.8+96-1.cdh5.4.8.p0.5.el6                                                                             Complete!   已经安装成功了,但是接下来还是有点问题: [root@zhumac1 ~]# which sqoop /root/sqoop-1.4.6/bin/sqoop [root@zhumac1 ~]# sqoop help Warning: /root/sqoop-1.4.6/bin/../../hbase does not exist! HBase imports will fail. Please set $HBASE_HOME to the root of your HBase installation. Warning: /root/sqoop-1.4.6/bin/../../hcatalog does not exist! HCatalog jobs will fail. Please set $HCAT_HOME to the root of your HCatalog installation. Warning: /root/sqoop-1.4.6/bin/../../accumulo does not exist! Accumulo imports will fail. Please set $ACCUMULO_HOME to the root of your Accumulo installation. Error: Could not find or load main class org.apache.sqoop.Sqoop [root@zhumac1 ~]#  这个很奇怪,怎么显示sqoop放在了之前下载的apache版本的文件夹里?我也没有在/etc/profile里面配置啊

wangxiaolei

赞同来自:

你自己的配置的有,我截图了:
图片.png
 

要回复问题请先登录注册