NN1切换为active时报错

NN1切换为Active时报错,具体情况如下,麻烦老师解答下,谢谢!

01.png

hdfs_site.xml配置如下:

02.png

NN1的日志如下:

03.png

hosts配置如下:

04.png

 

wangxiaolei

赞同来自:

JournalNode 都在那几台启动的。是否启动成功。

Eric_Jiang - 我是小象的搬运工!!!

赞同来自:

 
  1. bin/hdfs haadmin -transitionToActive nn1
你能发下你yarn-site.xml的配置么

zhongyu

赞同来自:

yarn-site.xml如下: <configuration>         <property>                 <name>yarn.resourcemanager.hostname</name>                 <value>hdp1</value>         </property>         <property>                 <name>yarn.resourcemanager.address</name>                 <value>${yarn.resourcemanager.hostname}:8032</value>         </property>         <property>                 <name>yarn.resourcemanager.scheduler.address</name>                 <value>${yarn.resourcemanager.hostname}:8030</value>         </property>         <property>                 <name>yarn.resourcemanager.webapp.address</name>                 <value>${yarn.resourcemanager.hostname}:8088</value>         </property>         <property>                 <name>yarn.resourcemanager.webapp.https.address</name>                 <value>${yarn.resourcemanager.hostname}:8090</value>         </property>         <property>                 <name>yarn.resourcemanager.resource-tracker.address</name>                 <value>${yarn.resourcemanager.hostname}:8031</value>         </property>         <property>                 <name>yarn.resourcemanager.admin.address</name>                 <value>${yarn.resourcemanager.hostname}:8033</value>         </property>         <property>                 <name>yarn.resourcemanager.scheduler.class</name>                 <value>org.apache.hadoop.yarn.server.resourcemanager.scheduler.fair.FairScheduler</value>         </property>         <property>                 <name>yarn.scheduler.fair.allocation.file</name>                 <value>${yarn.home.dir}/etc/hadoop/fairscheduler.xml</value>         </property>         <property>                 <name>yarn.nodemanager.local-dirs</name>                 <value>/data/software/hadoop/hadoop-2.6.2/local</value>         </property>         <property>                 <name>yarn.nodemanager.remote-app-log-dir</name>                 <value>/tmp/logs</value>         </property>         <property>                 <name>yarn.nodemanager.resource.memory-mb</name>                 <value>1024</value>         </property>         <property>                 <name>yarn.nodemanager.resource.cpu-vcores</name>                 <value>1</value>         </property>         <property>                 <name>yarn.log-aggregation-enable</name>                 <value>true</value>         </property>         <property>                 <name>yarn.nodemanager.aux-services</name>                 <value>mapreduce_shuffle</value>         </property> </configuration>  

zhongyu

赞同来自:

JN启动情况如下:
06.png
07.png
08.png
 

fish - Hadooper

赞同来自:

-ns后面跟的那个hadoop-cluster1是从哪里来的?

wangxiaolei

赞同来自:

董老师讲的federation方式分hadoop-cluster1和hadoop-cluster2 从你的配置文件看,没有配置hadoop-cluster1。 配置的是hadoop-test,所以你输入的命令不对。  

zhongyu

赞同来自:

我知道问题所在了,董老师讲义中那个地方标红了,是需要替换自己的dfs.nameservices,谢谢。

要回复问题请先登录注册