Kylin Build 示例Cube时报错——Snappy编码问题,求解!

目前组件采用以下版本:
Apache 2.7.2
HBase 1.1.3
Kylin 1.3-HBase1.1.3
kylin中的conf/kylin_job_conf.xml和conf/kylin.properties相关的编码已经注释掉,Hadoop中的编码相关的配置属性同样注释掉。但是仍然报错如下:
 
java.lang.RuntimeException: native snappy library not available: this version of libhadoop was built without snappy support. at org.apache.hadoop.io.compress.SnappyCodec.checkNativeCodeLoaded(SnappyCodec.java:65) at 
 
这是什么原因呢?原理上来说,注释掉所有压缩编码相关的属性,应该不会有这个问题呀

xujiao126113

赞同来自: fish StackOverFlow Anna008

已经解决,把所有用到压缩的地方先改为false,然后注意hive-site.xml中几项配置

助教_岑玉海

赞同来自:

检查过所有的配置文件了么,包括hadoop的,一般来说,如果禁用掉这些snappy的操作是不会再有问题的。另外还要看看是不是它有些地方默认使用了snappy了

xujiao126113

赞同来自:

@助教   (为啥我不能直接回复你)查看了,1、Hadoop的所有配置文件,与压缩相关的;2、HBase(无Compress相关的配置);3、Kylin配置

fish - Hadooper

赞同来自:

错误栈是否能也贴一下?

要回复问题请先登录注册