sparkSQL 集群运行报错

集群启动spark shell执行spark sql操作,报了如下异常

Caused by: ERROR XSLAN: Database at /home/felix/metastore_db has an incompatible format with the current version of the software.  The database was created by or upgraded by version 10.11.

最开始几次执行的时候没有这个问题,用的是derby数据库。

zp0824 - 好好学习,天天向上

赞同来自:

删了之后再试试,deby很少用的,不知道具体是什么问题了。生产环境都是配置mysql作为元数据库的,deby是没有人用的,所以学习的话,也最好连接hive的元数据

存在 - 一句话介绍

赞同来自:

好的

要回复问题请先登录注册